OpenSprinkler Forums Hardware Questions OpenSprinkler Pi (OSPi) Did I get the wrong relay?

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #60890

    ivwshane
    Participant

    I bought this 5v 8 channel relay and I have it hooked up to a pi zero w. Using ospi I can trigger the pi to open/close the various channels with no problems. When I hooked it up to a 24v AC sprinkler valve nothing happened on the valve side. I had two wires, one was a common wire and the other was for the valve itself.

    https://www.amazon.com/gp/aw/d/B0057OC5WK?psc=1&ref=ppx_pop_mob_b_asin_image

    I have the pi powered vi a 2.5amp 5v power supply and the relay is using 5v off of the pi for power.

    What am I doing wrong or did I need a 24v board like this one:

    https://www.amazon.com/NOYITO-8-Channel-Optocoupler-Automation-Industrial/dp/B07BLWZQZB/ref=mp_s_a_1_3?keywords=8%2Bchannel%2B24v%2Brelay&qid=1559950561&s=gateway&sr=8-3&th=1&psc=1

    #60903

    Peter
    Participant

    Have you just connected the two wires from the valve directly to two terminals of a particular relay ? If so then that wont work. There are two very separate circuits here and both of them need power. Firstly, the logic side of the relay (i.e. the side connected to the OSPi) needs a 5V supply but the Relay side of the board (the big green screw connectors) needs 24V to drive the valves.

    The board you have looks fine. Just connect the positive side of a 24V supply to the input pin on one of the relays, then connect the NO (normally open) pin to the active wire on the valve, then connect the common wire on the valve to the ground wire from the 24V power supply. That way when the OSPi “closes” the relay switch, the relay will connect 24V across the valve.

    #60955

    ivwshane
    Participant

    Excellent! Thank you!!

    #61424

    dzvero
    Participant

    Hey ivwshane , can you share how di you connect that relay board?

    • This reply was modified 8 months ago by dzvero.
Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.

OpenSprinkler Forums Hardware Questions OpenSprinkler Pi (OSPi) Did I get the wrong relay?