OpenSprinkler Forums OpenSprinkler Unified Firmware Downgrade issue from 2.0.2 to 2.0.0

  • This topic is empty.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #22721


    Hi All,

    I had a pre built unit that had 2.0.0 pre installed and working.
    Performed the update to 2.0.2 which was successful however had an issue with the sd card and would not get a dhcp ip address.

    This is when it all went terribly wrong as I then tried to upload the 2.0.0 firmware again to back out with the following which seemed to work.

    However now have no display or anything at all. I can plug the unit into a PC and it shows up the USBtinyISP AVR Programmer in device manager however am kind of stuck now on what I have done is recoverable.

    Any suggestions would be great.

    Detail from downgrade from 2.0.2 to 2.0.0 which caused the issue
    avrdude -c usbtiny -p m328p -F -U flash:w:firmware2.0.0.hex
    avrdude: AVR device initialized and ready to accept instructions
    Reading | ################################################## | 100% 0.05s
    avrdude: Device signature = 0x1e9609
    avrdude: Expected signature for ATMEGA328P is 1E 95 0F
    avrdude: NOTE: FLASH memory has been specified, an erase cycle will be performed
    To disable this feature, specify the -D option.
    avrdude: erasing chip
    avrdude: reading input file “firmware2.0.0.hex”
    avrdude: input file firmware2.0.0.hex auto detected as Intel Hex
    avrdude: ERROR: address 0x8010 out of range at line 2049 of firmware2.0.0.hex
    avrdude: write to file ‘firmware2.0.0.hex’ failed
    avrdude: safemode: Fuses OK
    avrdude done. Thank you.



    Ok I have managed to get 2.0.2 back on the unit thankfully.

    However still getting the same issue as before where when starting the unit im getting “A microSD card is required.”

    I have tried two different microSD cards (128mb and 2gb) with the files copied locally however still get the same issue when restarting the unit.

    If i eject and insert the microSD card at this point it then gets to the NTP Syncing screen however It never gives me a DHCP address and by pressing B1 gives me

    I have set the ip to with a gw of however it still will not take the static ip and still shows in the IP address when pressing B1.

    Should the microSD card be formatted with fat32 or something else?




    1) Regarding downgrading to 2.0.0, the issue was because you used ‘-p m328p’ in the command. It should be ‘-p m644’ because OpenSprinkler 2.0 uses ATmega644 microcontroller, not mega328.

    2) Regarding microSD card problem, how did you format the SD card? I’ve had issues when formatting the card in Linux. It should be formatted to FAT16. Somehow when I formatted it in Linux it wasn’t recognizable, but it was fine when formatted in Windows. I will investigate the issue later.

    3) I’ve just released firmware 2.0.3 in Github. Please my next post for details. Basically 2.0.3 uses Javascripts stored at by default, and provides an option to change the Javascript url if you need. For example, if you want to host it locally on the controller, you can copy files to a microSD card, pop it in, and change the Javascript url to . (i.e. a dot). For details please see the next post.



    Thanks ray the update to 2.0.3 that doesn’t require the ad card worked a treat.


Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.

OpenSprinkler Forums OpenSprinkler Unified Firmware Downgrade issue from 2.0.2 to 2.0.0