OpenSprinkler Forums Hardware Questions OpenSprinkler Pi (OSPi) Firmware upgrade of Rayshobby Raspi 1.2 doesn't work

This topic contains 7 replies, has 3 voices, and was last updated by  garlicpi 3 weeks, 6 days ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #62018

    tdk408
    Participant

    I am an early adopter. I just discovered my board is a “Raspi 1.2” made by Rays Hobby dated 6/2013.

    I try to upgrade firmware 1.9.0 to the latest using the Firmware Update Guide. It appears to work without error, but I am still at version 1.9.0.

    I did this twice with a linux expert at my side. I know I did not issue the wrong commands.

    I thought Rays Hobby and Open Sprinkler were the same people. Is there something about the configuration of the Raspi 1.2 board that is incompatible with the “universal” firmware?

    #62020

    Ray
    Keymaster

    If you are referring to the Unified OpenSprinkler Firmware: there is no firmware 1.9.0. The latest firmware is 2.1.8. Instructions are here:
    https://openthings.freshdesk.com/support/solutions/articles/5000631599-installing-and-updating-the-unified-firmware

    1.9.0 is likely a third-party firmware not written by us.

    #62021

    tdk408
    Participant

    Hi, Ray. Thanks for answering. I bought this unit from you on October 24, 2013.

    I looked into it and you are right. I am apparently running the Python port written by Dan_in_CA. I’m not married to it, but it did solve some problem I had with the original firmware back in 2014 or so.

    I am willing to run the Unified firmware, but the instructions at the link you gave didn’t work. I had a kernel-programmer Linux expert looking over my shoulder, and we did it twice.

    Does the unified firmware work with version 1.2 of your board?

    Thanks, Tom

    #62022

    Ray
    Keymaster

    Can you be more specific what ‘didn’t work’ means? What error messages and so on?

    #62025

    tdk408
    Participant

    After following the instructions for upgrading the firmware (twice), I still have the same firmware.

    This version 1.2 board has the firmware on an SD card. Do I have to do anything special in this case?

    Thanks,

    #62026

    Ray
    Keymaster

    Did you look at Section C of the instructions? (Stopping various versions of sprinkler program from running)

    If that doesn’t work, just burn a new Raspbian from scratch and follow the instructions to install firmware.

    #62032

    tdk408
    Participant

    I will try it, Ray. Many thanks.

    #62338

    garlicpi
    Participant

    Hello,

    I have a OSPI 1.4 board on a pi1 and just reloaded it with NOOBs and I can connect it to fine and set the timer for a zone but it never activates? Is this because I used NOOBs and need to load Raspbian not using NOOBs?

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

OpenSprinkler Forums Hardware Questions OpenSprinkler Pi (OSPi) Firmware upgrade of Rayshobby Raspi 1.2 doesn't work