OpenSprinkler Forums OpenSprinkler Unified Firmware Fresh install, unable to save the Station handling – Station Delay setting

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #65903

    alco
    Participant

    Hi,

    I’m using the OSPI software for about 1 year now and it works very well for our garden watering system. So many thanks for that!

    But now I have a small issue, I upgraded my raspberry PI and installed a fresh copy of the application (2.1.9.(3)) on the RPI.
    Works great again, but one option is not saved to the configuration after setting it.

    I attached a printscreen. I want to set the station delay to a few seconds, so I open the setting, adjust it, saved it , submit it. but it isn’t stored in the configuration!

    I also checked the filesystem on the OSPI, I see a change in the iopts.dat file (timestamp change) but I can’t read it with notepad++ or so.
    also there is no output on the systemlog (journalctl) of in the logs directory of ospi.

    So maybe a small bug somewhere? I’m happy to investigate and help but I don’t know where to start.

    #65912

    Ray
    Keymaster

    I am not aware of this being an issue for OSPi, but I will take a look.

    #65919

    Ray
    Keymaster

    Ah, ok, I figured out why: station delay time is quantized to every 5 seconds. So if you set a delay time below 5 seconds, it will be rounded to 0. You can set it in multiples of 5.

    #66277

    alco
    Participant

    Thanks for your continues support Ray!

    I can confirm that your solution worksconfirm that your solution works (screen GIF capture)
    set it to 13 seconds, saved, looked back, 10 seconds 🙂

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.

OpenSprinkler Forums OpenSprinkler Unified Firmware Fresh install, unable to save the Station handling – Station Delay setting