OpenSprinkler Forums Hardware Questions OpenSprinkler Pi (OSPi) I cannot for the life of me get a scheduled program to run!

This topic contains 4 replies, has 0 voices, and was last updated by  dblessing 6 years ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #22525

    mattguy
    Member

    EDIT!!!!!!!!!!! RIght when I posed this I checked the repo again and noticed a new version was posted just today so I tried it….and it WORKED! It fixed what ever bug was BUGGING ME! THANK YOU!

    So if you’re having any issues with scheduling or programs running, UPDATE!

    I have tried everything I can think of. I have rebooted, checked the times, checked the time zone, started the script manually, etc etc. I can manually turn on a zone and I can also use a “run once” program, but a scheduled program just will not run. I have manual turned off, rain sensor off, rain delay off, and operation is set to on.

    Here is my program –
    Program 1: Mon Tue Wed Thur Fri Sat
    Time: 00:00 – 23:50 , Every 3 hrs 0 mins,
    Run: 2 mins 0 secs.

    It does show in the preview program where the zones are SUPPOSED to turn on, but they don’t. There is nothing in the log besides where I turn it on manually (yes I do turn manual off after testing).

    Any suggestions?

    edit: Yes I also just git cloned the latest ospi.py from the repo dated June 26th, and it still doesn’t work.

    #24792

    russyahoo
    Member

    I’m having the exact same issue. However, I completely reloaded the OSPI interval program last night and I’m still having the issue. Is that the update you were referring to?

    #24793

    dblessing
    Member

    I am also having issues with the scheduled programs. I see them on the program preview but they never run. All other functions work fine. Is there any cron or other piece missing to get scheduled programs to run?

    #24794

    russyahoo
    Member

    I think I just figured out why the programs were not running.

    Apparently, the system clock in the Pi does not match the clock that shows in the interval program.

    When I manually set time in the pi, the program started running.

    Now I need to figure out why they are not in sync.

    Any help out there?

    Russ

    #24795

    Dan in CA
    Participant

    Is the time zone setting on the options page correct for your location?

    If so,the time displayed on the main page should be correct or you can change the TZ setting make the displayed time match your local time..

    Dan

    #24796

    dblessing
    Member

    I can confirm that the timezone was the issue. I first set the timezone via an environment variable. Apparently that doesn’t work for this scenario. I followed the instructions in this guide and things started working as expected. http://elinux.org/RPi_Beginners#Timezone

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

OpenSprinkler Forums Hardware Questions OpenSprinkler Pi (OSPi) I cannot for the life of me get a scheduled program to run!