OpenSprinkler Forums Comments, Suggestions, Requests IFTTT – Maker is now Webbhooks

Viewing 24 posts - 1 through 24 (of 24 total)
  • Author
    Posts
  • #53035

    kengrant
    Participant

    Hi

    I have just been trying to set up IFTTT for opensprinkler (love it!). I see the instruction on page 10 of the manual:

    For trigger service (this), search and select ‘Maker’. Set sprinkleras the ‘Event Name’ of the web request

    I think it should now read:

    For trigger service (this), search and select ‘Webhooks’. Set sprinkleras the ‘Event Name’ of the web request

    I read on the IFFTT site that : The Maker Channel has been renamed — it’s now the Webhooks service!

    Hope this help someone.

    Ken

    #53375

    Ray
    Keymaster

    Yes, I am aware of the change. Will be updating all manuals to refer to webhook. Thanks.

    #61828

    Kunstflieger
    Participant

    Hello Ray,
    is there a new manual refers to webhooks? I couln´t find it.

    Thanks
    Kunstflieger

    #62748

    Ray
    Keymaster

    IFTTT has changed a lot over the past year, it’s not possible for us to keep updating the user manual to keep up with their changes. But overall the changes are small and it should be easy to use existing instructions and adapt to their new changes. Just search for Webhooks in IFTTT.

    #65404

    WildBillpdx
    Participant

    I’m trying to setup IFTTT to send email using webhooks however it isn’t working. I’ve setup events for various items as shown in the attachment but never receive any email. I’ve double checked I’m using the appropriate IFTTT key so I was wondering if anyone might have some idea as to why it isn’t working.

    #65452

    Ray
    Keymaster

    I am looking into this issue. It seems IFTTT has changed significantly from the last time I logged in, the entire interface, and some features in the past have disappeared. They might have been moving towards a paid platform. I will do some research and report back.

    #65454

    Ray
    Keymaster

    Never mind, I was able to get it working again. Somehow the ‘create your own applet’ is only showing up in their app and not in browser interface. In any case, please let me know some details of your setup, such as what are you using as action (notification? text message? email?)

    #65463

    WildBillpdx
    Participant

    I setup the applet for email. When I check activity on IFTTT is shows as never having been triggered. I’ve double checked my IFTTT key multiple times and it appears to be correct. My OpenSprinkler info: Firmware 2.1.8 (2), App Version 2.1.10.

    #65466

    Ray
    Keymaster

    How long is your IFTTT key? Since you are on firmware 2.1.8, I suspect the issue maybe that the IFTTT key length exceeds what’s allowed in firmware 2.1.8. You should consider updating to firmware 2.1.9(3), the latest version — it allows much longer string size so if key length is was the cause then it should be solved by updating firmware.

    #65471

    WildBillpdx
    Participant

    Updated to 2.1.9(3) but I don’t think it made any difference. No email after restoring config and restarting OpenSprinkler system.

    #65470

    WildBillpdx
    Participant

    Seems to be 21 characters…

    #65472

    WildBillpdx
    Participant

    Here is a screenshot from the IFTTT applet …

    #65477

    Ray
    Keymaster

    Note that ‘Event name’ should be sprinkler, not OpenSprinkler.

    #65478

    WildBillpdx
    Participant

    Changed event name to sprinkler but still no luck.

    #65481

    Ray
    Keymaster

    OK, it seems you are on IFTTT platform, which I haven’t used so far. Here is what my applet looks (attached), it seems quite different from yours. I am on standard IFTTT account, used my mobile app to set up the applet.

    #65483

    WildBillpdx
    Participant

    Finally found the problem, though not sure how it originated. I changed the Event Name to Sprinkler on the applet, but it was still “OpenSprinkler” on the applet I was running. Changed it there and now it works.

    #65486

    Ray
    Keymaster

    OK, good to know.

    #65738

    WildBillpdx
    Participant

    New question…I attached a rain sensor to my system and it is working so watering is stopped. However, I still receive notices of programs being run. The emails don’t mention the rain sensor or the fact that the water actually didn’t run. Is this normal? I can see on the main screen that the rain sensor is activated but the logs don’t show any activity.

    #65748

    Ray
    Keymaster

    That’s a bug in the program which we haven’t fixed. Basically, what’s happening is that programs are always scheduled whether rain sensor is active or not. However, rain sensor status is applied at much lower level — where solenoid actions happen. The reason it’s done this way is that different zones may have different attributes, so you may have a program that contains zones that are not affected by rain sensor. For that reason, the program scheduling does not check rain sensor status, and so you will still receive notification about program being scheduled, even if no zone is actually running. This is on our todo list to be fixed in the future.

    #66038

    WildBillpdx
    Participant

    Does anyone know if there is currently a problem with webhooks email? I’ve been using it to send notifications for a couple of weeks now but as of today I’m not receiving email even though webhooks shows it has sent messages.

    #66084

    Wokkeltje
    Participant

    I have the same issue, mail is not working in IFTTT. my feeling is that IFTTT is EOL, a lot of companies stop the IFTTT integration because of changes prices.

    #66300

    Ray
    Keymaster

    I just tried it and it’s still working for me (tried all of email notification, SMS, push notification, all working). Here is what I did:

    – I had to use the IFTTT mobile app because when I log to IFTTT website, I can’t find the ‘make your own applet’ link. I noticed that the website seems to lead users to go to IFTTT Platform. Don’t use that — the firmware has never been tested with IFTTT Platform, and I have no idea how well it works.
    – Log into the mobile app, and at the bottom of the homepage, select ‘Get more’ -> ‘Make your own from scratch’.
    – Select webhooks as ‘this’, email (or SMS or push notification) as ‘that’. Make sure event name must be ‘sprinkler’ (without the quotes). If you don’t fill the event name or you use the wrong event name, you won’t receive notification.
    – Go to your webhooks documentation link to find the IFTTT token. Then put it in OpenSprinkler settings->Integration->IFTTT token, and selected a few events, like ‘station run’.
    – Manually run a zone and at the end of it you should receive the ‘station run’ notification.

    Update: just noticed that the website also works, just click ‘Explore’ at the upper-right corner, then ‘Make your own from scratch’ the Create button.

    #66307

    WildBillpdx
    Participant

    It was down for several days and then just started working again. Some problem with IFTTT platform apparently.

    #68272

    WildBillpdx
    Participant

    Any thoughts on moving to a different system for notifications since IFTTT is going to charge for access or restrict free account to three applets?

    https://ifttt.com/explore/introducing_ifttt_pro

Viewing 24 posts - 1 through 24 (of 24 total)
  • You must be logged in to reply to this topic.

OpenSprinkler Forums Comments, Suggestions, Requests IFTTT – Maker is now Webbhooks