OpenSprinkler Forums Hardware Questions OpenSprinkler Pi (OSPi) Interval Program has a great new interface

  • This topic is empty.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #22778

    Dan in CA
    Participant

    Jonathan Marsh has been developing a really cool new interface for the Python Interval program.
    It is now ready for Beta testing and is available on GitHub.

    Among the changes is a new login page (default password = opendoor).
    The home page now incorporates the program preview so you can see the status of irrigation schedules at a glance.

    [attachment=1:qpy7maeq]Home-Prog_running.png[/attachment:qpy7maeq]

    The Options page is neatly categorized with collapsible sections. The System section contains a System name and a Location field to help manage multiple controllers.

    [attachment=0:qpy7maeq]Options-system.png[/attachment:qpy7maeq]

    To get the new version you can do a “git pull” from the OSPi directory if your software was installed from GitHub or from the pre-configured image file.
    Log into the OSPi directory and issue the following command:

    git pull

    Otherwise you can clone a new install from GitHub by following instructions on the wiki.
    http://rayshobby.net/mediawiki/index.php?title=Python_Interval_Program_for_OSPi#Quick_Instructions:

    With this version you can switch back and forth between the original UI and the new one using the following instructions. Your options settings and programs will remain intact across both.

    To switch from the original inteface to the new one:
    1. log into the OSPi directory and issue the following command:

    git checkout JM_UI

    You should see a message that git has changed the branch to “JM_UI”.

    2. Restart the interval program (This assumes the program is set up to auto start at system boot):

    sudo service ospi restart

    or

    sudo /etc/init.d/ospi restart

    If you have the program open in a web browser, refresh the page using the browser’s reload button.

    To switch from the new interface back to the original one:
    1. log into the OSPi directory and issue the following command:

    git checkout master

    You should see a message that git has changed the branch to “master”.

    2. Restart the interval program (This assumes the program is set up to auto start at system boot):

    sudo service ospi restart

    or

    sudo /etc/init.d/ospi restart

    If you have the program open in a web browser, refresh the page using the browser’s reload button.

    Notes:
    The Raspberry Pi’s processor is relatively slow and low powered so it takes a couple of seconds to do a page refresh with the new UI. If it looks like nothing is happening after you click a button, check the browser’s status line (usually at the lower left corner of the browser window). You should see a message “Waiting for …”. I am looking into ways to improve response time.

    If you are using Samer’s mobile web app you will need to access the main program using the URL of your OSPi and appending :8080 (port number).

    Since this is the first Beta release of the new UI there will be some bugs, including –

    Known bugs:

      1. Only the first program shown in the program preview on the home page is at the correct start time. All programs will continue to run correctly however.

      2. In Manual mode, the buttons do not automatically change to show when a station has finished its run. You need to refresh the page using your browser’s reload button.

      3. The time shown at the left of the home page does not pay attention to the time zone setting in Options. The main program uses the options time zone setting and if it is not set correctly the scheduled programs can be off by as much as several hours depending on your location. I suggest making sure your TZ setting is correct while in the original UI.

    Please check out the new UI and let us know your comments, suggestions, etc.

    Dan

    #26130

    Ray
    Keymaster

    Very impressive. I am so glad OSPi now has such a polished UI. A big thank-you to Jonathan and Dan for working on this!

    #26131

    djagerif
    Participant

    Looks great guys. I am however getting the following after following the steps in the first post.

    127.0.0.1:56979 – – [06/Mar/2014 05:31:02] “HTTP/1.1 GET /” – 303 See Other
    127.0.0.1:56980 – – [06/Mar/2014 05:31:03] “HTTP/1.1 GET /login” – 200 OK
    127.0.0.1:56981 – – [06/Mar/2014 05:31:03] “HTTP/1.1 GET /sn0” – 401 Unauthorized
    192.168.0.36:54008 – – [06/Mar/2014 05:31:37] “HTTP/1.1 POST /login” – 303 See Other
    Traceback (most recent call last):
    File “/home/pi/OSPi/web/application.py”, line 239, in process
    return self.handle()
    File “/home/pi/OSPi/web/application.py”, line 230, in handle
    return self._delegate(fn, self.fvars, args)
    File “/home/pi/OSPi/web/application.py”, line 420, in _delegate
    return handle_class(cls)
    File “/home/pi/OSPi/web/application.py”, line 396, in handle_class
    return tocall(*args)
    File “/home/pi/OSPi/ospi.py”, line 636, in GET
    return render.home()
    File “/home/pi/OSPi/web/template.py”, line 881, in __call__
    return BaseTemplate.__call__(self, *a, **kw)
    File “/home/pi/OSPi/web/template.py”, line 808, in __call__
    return self.t(*a, **kw)
    File “templates/home.html”, line 368, in __template__

    loading…

    IndexError: list index out of range

    192.168.0.36:54008 – – [06/Mar/2014 05:31:44] “HTTP/1.1 GET /” – 500 Internal Server Error
    127.0.0.1:56982 – – [06/Mar/2014 05:32:01] “HTTP/1.1 GET /” – 303 See Other
    127.0.0.1:56983 – – [06/Mar/2014 05:32:03] “HTTP/1.1 GET /login” – 200 OK
    127.0.0.1:56984 – – [06/Mar/2014 05:32:03] “HTTP/1.1 GET /sn0” – 401 Unauthorized

    I think I found the problem. I am using 5 expansion boards and setting it back to 0 loads the main page correctly.

    #26132

    QMan
    Blocked

    I got a similar error testing the new UI, but it is because my system does not use the default password. There is “opendoor” hardcoded in ospi.py file, so I switched back to master. Looks great though!

    #26133

    Sepp1945
    Member

    Hi,

    I am using the program (very nice interface) successfully, but one little annoyance .. each program runs twice .. eg one station runs, then the second station, program finishes and starts again station 1 , then station 2 and finishes. this happens every time, I have deleted the programs now twice , and created them new, but to no avail.

    Any help is very much appreciated

    Many thanks

    Sepp

    #26134

    gaslan
    Member

    I had the same problem, and it seems to be that the recurring option (in each schedule) is set (and for a reason I don’t know it reverts), I’ve just set to repeat schedule that starts at 10pm to repeat every 5 hours until 11pm… After that it seems to work ok…

    #26135

    Lamby
    Participant

    I love the interface, but it does not work with the new mobile app. The reply I got from salbahra (writer of mobile app) was that the new interface “lacks the the addons API and specifically the mobile_api plugin”.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.

OpenSprinkler Forums Hardware Questions OpenSprinkler Pi (OSPi) Interval Program has a great new interface