Tagged: 

This topic contains 3 replies, has 3 voices, and was last updated by  Ray 6 days, 15 hours ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #49230

    Miles
    Participant

    I am able to login to the web on port 8080, and the app on my android also works fine. I am trying to get this working with Home Assistant, which led me to check a couple of URLs. Making requests with with /jn, /je, etc. always returns {“result”:2}. /ja returns {“fwv”:217}. In other words, I can’t even get a station list much less anything else. I am passing the password as md5 per their suggestion.

    Running on raspberry pi, version 2.1.7 with app version 1.7.3

    • This topic was modified 1 year, 2 months ago by  Miles.
    #49232

    Miles
    Participant

    … my password had a ‘!’ in it. Once I changed it to something else without that, it works. Thank you, drive through.

    #59472

    Francois Terblanche
    Participant

    Hi,

    I had the same issue on 2.1.8. I had to disable password (Edit Options -> Advanced -> Ignore Password) before I could get API to return anything other than {result: 2}.
    Also see: https://opensprinkler.com/forums/topic/is-the-api-working-on-firmware-2-1-3/

    My password did not have any special characters in it.

    Regards,

    Francois.

    #60370

    Ray
    Keymaster

    One thing to keep in mind is that all recent firmwares expect the password to be MD5 hashed, not plain-text. For example, the default password is opendoor but if you are using the API or third-party plug-in, the HTTP API expect the password in MD5 form (the MD5 of opendoor is a6d82bced638de3def1e9bbb4983225c). If you send the plain-text password it will be rejected.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.