OpenSprinkler Forums OpenSprinkler Unified Firmware Metric units using Openweathermap

This topic contains 6 replies, has 3 voices, and was last updated by  Samer 2 weeks, 6 days ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #54193

    bretskee
    Participant

    Hi,

    Since I deleted my WU key, weather updates SEEM to be working however the adjustment parameters screen now displays in degrees F and inches. Is there a way to return to centigrade and millimetres.

    Thanks

    #54194

    Samer
    Keymaster

    This should still happen automatically based on region. I just tested Paris for example and the UI switched to centigrade but the US shows fahrenheit.

    What region are you using?

    #54204

    bretskee
    Participant

    Hi Samer,

    I am in Sydney Australia. I too selected Paris on the map but I still see imperial units. I rebooted by Pi as well. I went back to region setting and saw Paris long and lat. Selecting Sydney again is still imperial. I am using OSPI 2.18(2). Also, whilst I have in the past, I am not seeing a successful weather call time in diagnostics this morning after the reboot. There is no key in the WU field. BTW, I still see imperial when there is a successful call.

    Thanks

    #54205

    Samer
    Keymaster

    The metric flag is decided based on the country returned from OpenWeatherMaps. Basically if it’s not US it will use metric system.

    What region are you using? Have you tried to force quit the app and reload it? Are you using the latest app? Is this web or app?

    Thanks.

    #55168

    bretskee
    Participant

    By region do you mean the map location selected in ‘Edit Options’ then yes. Please see the attached images. The coordinates are in the Sydney Australia region. As I said above, I also selected the Paris region and still see imperial. This is WEB. I just tried the App and it displays correctly in Metric.

    #58214

    psmedley
    Participant

    Possibly related, but we actually received some rain here in Adelaide yesterday – not much, only about 1.1mm. However, Opensprinkler turned the water down to 0% and showed that 28mm was received – almost like it was taking the number of mm recorded, thinking it was inches; then converted it to mm?

    #60065

    Samer
    Keymaster

    We had a unit issue which was identified by @PeteBa who also issued a PR to resolve it. We have merged it and pushed it to production now.

    Thank you!

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

OpenSprinkler Forums OpenSprinkler Unified Firmware Metric units using Openweathermap