OpenSprinkler Forums Hardware Questions OpenSprinkler OpenSprinkler 3.0 Expansion Boards

  • This topic has 3 replies, 2 voices, and was last updated 6 years ago by Ray.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #50496

    info17
    Participant

    Hi,
    I bought one OpenSprinkler 3.0 to change my damaged OpenSprinkler 2.0. Now i noticed that the Expansion Board connector have more pins, and in manual talks about zone expander unique index , by hardware.

    My question, can we use the old expansion boards with this OpenSprinkler 3.0?
    If yes what will be the pinout?

    Best Regards,
    Alex

    #50564

    Ray
    Keymaster

    Expander 3.0 can only work with OpenSprinkler 3.0. If you have OpenSprinkler 2.x or OpenSprinkler Pi, you need Expander 2.1. You are right that the connectors have changed to avoid accidentally plugging in the wrong expander to the main controller. But it’s more than just a connector change: expander 2.1 and 3.0 work completely differently and so are not compatible at all. If you haven’t done so, you can send a support ticket to arrnage for an exchange.

    #50571

    info17
    Participant

    Hi Ray,

    Sorry i think i do not explained me well.

    In this installation i have 1x Opensprinkler 2.0 and 2x expansion boards. The Opensprinkler 2.0 died with power problems, i order at schlaugarten one Opensprinkler 3.0, and dont expected that have changes in expansion system.

    But i have other instalations were i can put this 3.0, so is not big problem.

    I think that can happen in future to more old clients, so one extra advise with the “incompatible with 2.0 expansion modules” will be recommended.

    Thank you for your time, and continue with this great project.

    Kind Regards

    #50681

    Ray
    Keymaster

    Sorry about the confusion. On the product page:
    https://opensprinkler.com/product/zone-expander/
    we do make it quite clear which version you should buy. Also, for orders that contain expander alone (without a main controller) we proactively check (by looking up prior orders and asking customers to confirm) if you have prior orders of main controllers that match the expander you ordered. We do have some users who have multiple versions of OpenSprinkler, in that case we may have skipped asking the customers to confirm, but will be more careful next time.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.

OpenSprinkler Forums Hardware Questions OpenSprinkler OpenSprinkler 3.0 Expansion Boards