OpenSprinkler Forums Third-Party Software OpenSprinkler for your Pebble watch

Tagged: 

This topic contains 38 replies, has 8 voices, and was last updated by  skyynet 1 week, 6 days ago.

Viewing 9 posts - 31 through 39 (of 39 total)
  • Author
    Posts
  • #40312

    DaveC
    Participant

    Hi. I’m not a ‘watch’ user, but here’s my $.02. I provide this capability in my automation app. At my home I only use the manual capability but I think it’s useful to provide both and allow people a ‘manual override’.

    #44359

    Wendell
    Participant

    I bought my OS hardware (it’s still the latest revision sold) quite a while ago and just got around to installing it yesterday. I’ve got it up and running, but I’d love to be able to use my Pebble Time to control it, and I’m running into a problem. Has anyone used David’s OpenSprinkler Pebble app with the current version of Pebble’s iOS app? I can download and install the OpenSprinkler app to my watch, but when I try to go into settings from the Pebble iOS app it tells me to check my internet connection and try again. I’ve got an internet connection, and the watch is connected to the phone correctly. I’m wondering if there’s something in the app that needs to be updated to support the more recent versions of software from Pebble? I’m current on my watch firmware and iOS app from Pebble. TIA for any help resolving this.

    Also, on a side note, I’m considering buying an Apple Watch now that they have a waterproof version (I use a watch to track my swimming, so waterproof is essential for me anyway). Does anyone know of an Apple Watch app that controls the OpenSprinkler hardware? I suspect the Pebble watches might be a better fit for in-the-yard system debugging due to the Apple Watch not having a lot of buttons and the touch screen probably not working well with wet or muddy hands, but I can still see where control from an Apple Watch would be useful when you’re not actually out in the yard messing with the system but still want to check on status or run a zone.

    #44362

    skyynet
    Participant

    Hi David,

    Great stuff. I feel like home with the OpenSprinkler. Ordered from the German Schlaugarten shop. As the order was mixed with another one the owner visited me today to exchange it! We talked a little and had a similar history with Gardena rubbish and now Hunter sprinklers. Now I stumbled over your Pebble app and as a Pebble user from day one on the Kickstarter funding, I installed it of course.

    Unfortunately the only thing I get when I try to open settings from the iPhone’s app is an error claiming there would be no internet connection which is not true.
    There’s also a yellow point on the left hand of the settings icon.

    I’m using a Pebble Time Steel with firmware and iOS app v4.2. My OpenSprinkler DC is hardware 2.3 and firmware 2.1.6(1).

    Hope to get this working.

    Ingo

    #44409

    Wendell
    Participant

    I’ve communicated with David via email, and the problem is that the webpage he was hosting to handle the settings is no longer working (something about dropbox shutting down an account). Anyway, the code is on github at https://github.com/littleprojects/Pebble_Opensprinkler, and you can pull this into CloudPebble (which you will have access to when you set up a customer account on the Pebble website). If you edit the app.js file in CloudPebble you can enter your “link” (IP address of your OS), “pass” (MD5 hash of your password… Google for an online MD5 hash generator and key in your password… copy and paste the resulting hash into the “pass” variable in app.js), and “name” of your OS device (I think it defaults to “home”). In app.js in CloudPebble look for a block of code that starts with

    if(demo){

    This is where you need to enter these 3 things. Now click the disk icon in the upper right to save your changes, then compile the app (from COMPILATION menu on left of CloudPebble screen), then click RUN BUILD, then select PHONE as your destination and click INSTALL AND RUN. Make sure the iOS Pebble app on your phone is set to “Developer (on)” from the … menu in the upper right corner.

    If all went well, CloudPebble should connect to your phone and install the OpenSprinkler app on it. From there, you’re ready to use it. It looks pretty cool.

    #44579

    David
    Participant

    Hey,

    sorry for the late response…

    I hoste the settings website on my dropbox account. And dropbox stop the host service… 🙁

    But i updated the watchapp last week. This should fixed the “Check you internet connection” Error.

    If youre still have problems, write my an email over the pebble app 🙂

    @skyynet i use my OpenSprinkler to drive Gardena valves too. With the OpenSprinkler i upgraded my system from 3 valves to 9. The Gardena Vales are very easy, you can drive them with 24V AC or DC. 😉

    #44598

    skyynet
    Participant

    Hi @david,

    Thanks for updating the Pebble App. I tried it again and got no “Check you internet connection” Error anymore.
    Setting up the prefs I have a few questions:

    1. Is the Device Name important?
    2. Do I have to enter the :8080 at the end of the IP?
    3. Do I have to enter the md5_hash or the password into the pw field?

    Currently I only get “Loading” on the Pebble’s screen after starting the app.
    I’m using the v2.1.7 Firmware on my OpenSprinkler 2.3 DC.

    If you run into trouble again with your hosting service just contact me. I run my website for about 20 years incl. SSL.
    You have the settings page on an external server instead of the phone app itself? May I ask why?

    #44613

    David
    Participant

    Hey @skyynet,

    hmm, i have to check this at my pebble. But i cant find my charging cable… :/ i have to order a new one. give me some days.

    to your questions:

    at the settingspage:
    1. the device name is uninportant, this is just for the headline of the welcome page in the pebble app.
    2. if you dont enter a port, it is default port 80. The default OpenSprinkler Port is 80. If you have a custom Port, you need to enter this after the IP (192.168.1.10:8080) or URL (myOSPIinTheWeb.com:8080)
    You can setup a IP or a link. Check the Ip or link in a browser.
    3. the settingspage convert you password into a md5 hash and send this to the pebble. enter your normal password.

    I made the pebble app for the version 2.1.4. Maybe there is a change in the API. Did you have a “Loading” or “Loading.” or “Loading..” or a “Loading…”?
    The dots indicats the API request. 😉

    #45682

    skyynet
    Participant

    Hi @david,

    Sorry for the long delay answering but I get no notifications from the OpenSprinkler Forums when someone answers.
    My problem was caused by setting port 8080 like in the default URL in the Pebble app. I just deleted the :8080 at the end and it works now.

    Too sad, Pebble development ended after Fitbit bought them. I hope Apple will improve battery life cause this is the only thing I don’t like on the Apple Watch.

    #57155

    skyynet
    Participant

    Two years later I bought a Fitbi Versa which comes pretty close to what a Pebble would look like today. I wonder if the Pebble App was translated into a Fitbit App. Fitbit bought the Pebble team and I think the SDK is pretty much the same.

    • This reply was modified 1 week, 6 days ago by  skyynet.
Viewing 9 posts - 31 through 39 (of 39 total)

You must be logged in to reply to this topic.

OpenSprinkler Forums Third-Party Software OpenSprinkler for your Pebble watch

We are away till Mar 22. Orders placed during this time will be shipped on Saturday Mar 23 . Thank you. Dismiss