OpenSprinkler Forums Hardware Questions OpenSprinkler Pi (OSPi) OpenSprinkler RasPi 1.2 – Fried Triacs

  • This topic has 1 reply, 2 voices, and was last updated 4 years ago by Ray.
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #45787

    kenb
    Participant

    My landscaper was out today and in the process of diagnosing why one of the valves wasn’t working he managed to fry additional stations.

    It appears I have three triacs that are blown. See uploaded image. From reading the forums I suspect that there’s no short protection for a station. I’m a beginner when it comes to sorting out parts but I’m ok with the soldering end of things.

    Two questions:

    – What part # do I need to replace these?

    – What can I do to prevent this in the future?

    I have OpenSprinkler RasPi 1.2

    — Ken

    Attachments:
    #45868

    Ray
    Keymaster

    The part is BT1308W (and equivalent substitute: Z0103MN). You can buy these from digikey.com or mouser.com. You can also send a support ticket so that we can ship you a few spare parts. Do note that these are surface mount parts — unless if you have surface mount rework tools, it’s hard to take them off using a soldering iron. Again, if you send a support ticket, we can arrange to repair it at a reasonable cost.

    There is a fuse on the 24VAC line to protect shorted circuit. I suspect that this damage might not be due to shorting but due to high transient voltages. OSPi 1.2 does not have built-in TVS diodes which are for protecting the triacs from high transient voltages.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.

OpenSprinkler Forums Hardware Questions OpenSprinkler Pi (OSPi) OpenSprinkler RasPi 1.2 – Fried Triacs