OpenSprinkler Forums OpenSprinkler Unified Firmware OS says “empty response” from local weather service (after update)

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #71225

    bekesizl
    Participant

    My PWS powered local weather service was working happily with my OS through the summer months.
    Last weekend I updated to firmware version 2.1.9 (9) from 2.1.9 (7) and made some tests to change the wifi access point.

    I am not sure if it is connected to the update, but OS is not getting data from the local weather service.
    I don’t know, where the problem is.

    PWS sends data, it is received my Meteobridge running on a RPi. -> checked, it is working
    Meteobridge sends data to the local weather service running on another RPi. -> checked, it is working
    For test purposes, NodeRed queries OS to calculate watering percentage with the call
    `http://192.168.1.OSIP/jc?pw=pwhash
    -> it has a plausible data
    System diagnostics at OS Web Interface says “Weather service: offline” and “Empty response” and it is not updating the watering percentage.

    I made a settings export before the update and reloaded the settings after the update.

    Field “weather” was filled with 192.168.1.25, the IP address of the local weather service at http://<your OS IP>:80/su

    What might have gone wrong?

    I switched back to DarkSky temporarily, but their rain data was extremely unreliable last summer.

    #71249

    franzstein
    Participant

    I encountered the same issue with often getting the OpenSprinkler “Empty Response” from my local weather service installed on a Raspberry PI. I encountered this issue with OpenSprinkler Firmware 2.1.9 (4), 2.1.9 (7) and actual with 2.1.9 (9). I think it’s not caused by the recent firmware update. The “Empty Response” isn’t always reported. Most of the time the weather service is requested successfully.

    I’ve done some investigations in June with OpenSprinkler Firmware 2.1.9 (4), and it is maybe worth to share my findings. My WiFi setup consists of a Fritz!Box 7590, a WiFi Repeater Fritz!WLANRepeater 310 and two PowerLines Fritz!PowerLine 1240E, Fritz!Powerline 1260E; all organized as a Mesh System. The Fritz!Box allows for monitoring and analyzing the intranet and internet traffic via WireShark. The OpenSprinkler installed in my garage connects to the WiFi Repeater as this is the nearest local network access. What I can see from the WireShark reports is, that there is no response data missing at all. Please have a look at the attached log files.

    Please note that I used a private firmware compilation that requests the weather service every 20 minutes to get this log files. I only changed the CHECK_WEATHER_TIMEOUT parameter in this compilation. Everything remains unattached.

    However, I’m not sure if the Fritz!Box capture feature really monitors the intranet traffic between the WiFi repeater and the OpenSprinkler? The data traffic logged is more likely what is captured in or close to the Fritz!Box? It might be interesting to move the OpenSprinkler next to the Fritz!Box, to see if the issue still exists, if no WiFi repeater is involved. I think I will investigate this during the winter season. I don’t need the OpenSprinkler garage installation during this time of the year.

    I can still think of let’s say an OpenSprinkler runtime error or some overload problem causing this “Empty Response” – issue. Let’s see if the OpenSprinkler team has some ideas what to do?

    #71254

    franzstein
    Participant

    @bekesizl: If you haven’t had any issues with your old WiFi setup, it’s maybe worth to use your previous WiFi setup again. Maybe everything is working with the old setup? It might be interesting to know if this solves the issue!

    #71259

    franzstein
    Participant

    Some additional information. For the above investigation I used a value of about 20 minutes (1201 seconds) for the CHECK_WEATHER_TIMEOUT parameter. With the OpenSprinkler firmware update to 2.1.9 (9) I’m using a value of about 60 minutes (3601 seconds) polling the weather service every hour.

    With firmware version 2.1.9 (9) the issue with the “Empty Response” occurs once twice sometimes three times a day. Please see the attached system status report. Looking at the Fritz!Box or Fritz!Repeater status reports there are no outages or other problems reported for the given weather service request times.

    #71263

    bekesizl
    Participant

    I didn’t had time during the week for experiments, Wifi is using the old “Access Point”.
    I didn’t manage to set up the Mikrotik AP until now.

    Today I changed back the used weather service from DarkSky to PersonalWeatherStation this afternoon.
    This evening the scale was updated. I will observe how it behaves in the future.

    I am pretty sure that the weather service script is working alright, as I built myself a flow in NodeRed, that queries Opensprinkler for the data for the query of the weather service, then queries the weather service and exports the scale. It was working alright through the whole week.
    I need this to be able to observe the weathering scale without using Opensprinkler webapp or anything OS related, as neither the OS API queries, nor the MQTT interface includes this value.

    How bad is the compilation of the firmware?
    Sometimes I would also like OS to update the scale more often, especially after a rain in the night.

    #71277

    bekesizl
    Participant

    Nothing changed in the settings or wifi setup since yesterday.
    Weather service report is understand by Nodered and scale displayed by HomeAssistant.
    Opensprinkler is online.
    Again “Empty response” and scale changed to 100%. I am switching temporarily to manual scale.

    #71286

    franzstein
    Participant

    bekesizl: Compiling the OpenSprinkler isn’t to complicated. You have to follow the instructions given in the OpenSprinkler Support section. Some hints are also given in the forum thread: Error building firmware from source.

    If you change the CHECK_WEATHER_TIMEOUT parameter in main.cpp to 1 hour as described above there is a good chance that you see the “Empty Response” answer only once or twice per day. In this way you can probably use your own local weather service for the OpenSprinkler Water% calculation.

    I’m not sure what causes the issue. I’s maybe some timing problem due to the longer data travel time if WiFi repeaters are in use. Maybe the OpenSprinkler team can give some hints on what causes the “Empty Response” in detail.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.

OpenSprinkler Forums OpenSprinkler Unified Firmware OS says “empty response” from local weather service (after update)