OpenSprinkler Forums OpenSprinkler Unified Firmware ospi version stuck at 2.1.7

  • This topic has 4 replies, 2 voices, and was last updated 3 years ago by Ray.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #52060

    RottenMutt
    Participant

    i get notified of new version but if i follow the instructions to update i’m still on 2.1.7!
    first my OpenSprinkler-Firmware didn’t exist so i did:
    cd ~
    git clone https://github.com/OpenSprinkler/OpenSprinkler-Firmware.git
    sudo ./build.sh ospi
    and restart

    i’m still on 2.1.7, is update not available for pi?

    #52429

    RottenMutt
    Participant

    Is 2.1.8 available for the RPI?

    #52493

    Ray
    Keymaster

    It is, but the only change in 2.1.8 that matters to OSPi is that it increased the maximum number of programs (from 17 to 35) and maximum number of expanded zones (from 56 to 72). If you don’t need these expanded programs and zones, 2.1.7 is no different from 2.1.8.

    #52656

    RottenMutt
    Participant

    then why won’t my system update?

    #52806

    Ray
    Keymaster

    You probably switched to a different branch some time the past. Switch back to the master branch and it should work.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.

OpenSprinkler Forums OpenSprinkler Unified Firmware ospi version stuck at 2.1.7