Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
  • #42047

    Csaba Toth

    I am brand new in Raspi, Linux and Opensprinkler.
    I have installed the firmware after a lot of struggling on a Pi2 board and get it functional on mobile browser too: Android/Chrome.
    I was strugling with a 4GB card: image was written, but it didn’t wanted to boot. This card is working well in a camera.
    Then a 32GB card was able to boot.
    I didn’t vunderstood why I don’t have HDMI signal, but learned to use the SSH and setup the wireless.

    But I couldn’t start the mobile Application, refusing the same IP&Port what working in the browser.
    That is only the minor problem what I have.

    I am going to install the system on Pi3 too. I had prepared 3 brand new 16Gb Sandisk Ultra card: ospi2.img (3,5GB) image copied to.
    I have access to 3pcs. of Pi3.
    In any combination of the boards and the SDs doesn’t work, no flashing leds, nothing happen.
    I have tried with the Pi2 using one of the same SD, worked well, the system has been set up flawless.

    Please tell me ho to install the firmware on Pi3?

    Thanks, Csaba



    Once you have a working Linux install (beyond the scope of the setup) all you have to do is follow three steps:

    git clone
    cd OpenSprinkler-Firmware
    ./ ospi



    I couldn’t get the stock img to boot on pi 3 either. I should install something like raspbian and build ospi on that? Thanks!



    Unfortunately the pre-configured SD card image hasn’t been updated to support RPi 3 yet. So at the moment you need to install a fresh Raspbian and follow what Samer said to install OpenSprinkler firmware.

    I know people often want the latest and fastest RPi, but honestly unless if you need the computation power of RPi 3, I would highly recommend sticking with RPi A+ as it’s one of the cheapest options, power efficient, and the computation speed is more than sufficient for a sprinkler controller 🙂



    Thanks, will try that. Agreed about the overkill, but I wanted to use what I have until I can procure an older rpi on the cheap. Everywhere I look the older models are almost as much as the rpi 3.


    Csaba Toth

    Thanks Samer!

    I was able to set up.
    It has booted once, I have changed the port. Then after reboot I couldn’t connect.

    It is not booting anymore, the task manager doesn’t show the OpenSprinkler task by itself.
    I have to start by hand to show in the tasks list.

    But even with manual starting there is a mistake I can’t reach the web server using the device IP.


    Csaba Toth

    Ray, at my suppliers the Pi2 is more expensive than Pi3, and right now only Pi3 available.
    Pi3: 35,3 USD, while Pi2 38,6 USD plus the wifi dongle! Older models are discontinued.

    When Pi-zero will be available, that can be the good option.


    Csaba Toth

    I have deep gaps in using the OpSystem….
    Now (I think) I can update, build, remove the Firmware.
    But I can’t start the application.
    Even when it appears in the Task Manager, not responding on the Ip address link.

    I would appreciate if I would get answers:
    How can I start the Application from the terminal?
    How can I make it autostart at boot? I tried the OpenSprinkler.launch description, but I have failed.
    How can I prevent the GUI to start at boot, to make it faster?

    Thanks in advance!



    Start the ‘application’? Which application are you referring to? The OpenSprinkler firmware compiles in command line (just run the script), and runs in the background and it’s essentially a HTTP web server. By application do you mean the user interface? You can access the web server by either typing in the IP address:8080 (where 8080 is the default HTTP port of the firmware), or by using the OpenSprinkler mobile app (again, put in ip address:8080 to the app)

    I have no idea what OpenSprinkler.launch is. Also, OpenSprinkler firmware does not require a GUI (no X required).


    Csaba Toth

    Excuse me Ray, I am not very familiar with the expressions. I am learning hard.

    I have a working Pi2 based Ospi, what was installed by the image dowloaded to an SD card.
    But I can’t do the same with a Pi3. I did according to Samer suggested.
    Still not succeded.

    I try to make it clear:
    I have installed the Pi3 Linux, then the Firmware as it was written above.
    The http server started once, not any more, since then I can’t access on the appropriate Ip address.

    I have a working Pi2 based ospi, what I can access in the same network, when I type the Pi2-ip address of the Pi2-OSPI, a version install description page comes up.

    If I try the Pi3-ip address: access denied.
    If I run in command line the script, nothing changed.

    I think the http server is not running at all.
    How can I check, the http server is running? I cant find it in the Task Manager.

    I don’t know what files should be in where to launch the server at boot?

    How can I cleanup the whole OpenSprinkler and start over again the installation?

    OpenSprinker.launch is a file in the Firmware folder, where the auto boot commands are written.
    I did according to this, no change.

    I know the GUI is not needed. This is why I asked how can I prevent from booting the GUI (after the http server works correctly).




    You will need to get comfortable using a terminal and command-line utilities to do the things you want. netstat can help you verify the web services are running:

    root@ospi:~# sudo netstat -ntlp
    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0    *               LISTEN      2250/apache2
    tcp        0      0  *               LISTEN      2078/OpenSprinkler
    tcp        0      0    *               LISTEN      2456/sshd

    Shows an apache2 process listening on all network interfaces ( on port 80 and the OpenSprinkler process listing on port 8080. Verify that you are connecting to the correct ip address. In general, it’s debian running, so searching for “linux …” or “debian …” should help you in the future. Hope that helps.


    Csaba Toth

    Dear Erik: thanks, this helped a lot.
    netstat shows what is in the background (pic).

    Now it is working. Probably it has worked all time.
    The mistake was, that I was regularly checking only the Ip address, looking for the welcome page, as it was the case on my existing and working Pi2 installation.
    But Pi2 was installed by the downloaded image file and that is different as I see.
    The Ip:Port address immediately linked to the page.

    About disabling the GUI:
    I don’t think that disabling the GUI is needed.
    As I experienced, the web server is launced before the GUI is started. The boot time of the server is about 30sec, what is acceptable.
    About the same boot time is measured on Pi2 installation what has no GUI.

    Thanks for the help.

    The next questions what I am facing:
    How to setup the time from the webpage?
    How the RTC is loaded by the right date/time?
    As I remember I haven’t done anything at the Pi2 install, and the time is correct. (see pics)
    In the Pi3 install it is wrong. Both set to the same timezone and location.

    I can set the time in command line, but I think this should work from the page.
    Is there a manual what to do?

    Is it possible to assign a name to the controller?
    Like House A, Cottage B….

    In the Edit Options/ Advanced menu there is a device ID.
    What is this for?

    Thanks for the help.



    1) By default the firmware uses UTC time obtained from RPi, and the time zone data it stores, to calculate the local time. The RTC is not directly used by RPi. Instead, as long as RPi is online, it will automatically perform NTP sync to obtain the current UTC time. You can set up RPi to sync with the RTC, so that even if there is no Internet, it can still get accurate time from the RTC. Again, setting up RTC is a separate step that’s apart from the firmware.

    2) I believe so. If you have multiple controllers, the OpenSprinkler UI/app supports multiple sites, and you can give each site a different name.

    3) The device ID is not relevant to RPi. It’s used in the past to distinguish multiple controllers on the same network. The background is that in the past the microcontroller-based OpenSprinkler had software-defined MAC addresses, and the last byte was defined by the device ID. RPi always has hardware defined MAC address (and all current versions of OpenSprinkler have hardware defined MAC address), so the device ID is not relevant any more.


    Csaba Toth

    1. RTC and real time:
    If I connected by Eth cable the real time is real.
    If I connected by wifi the link is not settled by the time the NTP is taken during boot and it starts from the last shutdown time.
    How can I setup the automatic NTP update in Rpi?
    I have inserted in /etc/rc.local: rdate -ns, but it works only by Ethernet connection.
    Using wifi it works in command line after booting, and that corrects the real time in the firmware.

    To use the RTC:
    a. we should have a manual “Time setup menu”: sync to NTP or ENTER the value. This writes the RTC registers to the real value.
    Or automatic update of the RTC from NTP some times, when the connection is fine.
    b. Then the firmware always should read the RTC for the real time operations.

    I would appreciate to read practical solution to have stable real time in the firmware.

    2. Where that given name should appear on the screen?


    Csaba Toth

    I think I found the answer of the RTC question:

    Does it works well with the current version?

Viewing 15 posts - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.