OpenSprinkler Forums OpenSprinkler Mobile and Web App Resets to default settings everytime I reboot and timezone

  • This topic has 5 replies, 4 voices, and was last updated 7 years ago by Ray.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #40718

    jeeva
    Participant

    Hi

    App version: 1.4.8
    Firmware 2.1.6 (1)
    Hardware Version: OSPi – AC

    I just finished with my setup (Already setup the timezone & localization through ospi config), however in the web application whenever I make a change and safe it, it commits.

    My problem is:
    1) the timezone shows -5 Boston, MA. However I’m Boston, ZA (Cape Town, Boston, South Africa) GMT+2. I’m unable to change the timezone in the web app it is greyed out.
    2) I read on the forums some people said that they rebooted the device to get it to work. However everytime I reboot the Raspberry Pi my Web application options are back to default.

    And ideas?

    #40720

    Samer
    Keymaster

    The OSPi uses the system clock for the time. So long the system is correctly set the time will be reported correctly and you can safely ignore the time zone setting.

    #40721

    jeeva
    Participant

    #40722

    Samer
    Keymaster

    Thank you for providing the screenshot. We will take a closer look and let you know.

    #40725

    sakos
    Participant

    Let me comment your issue. I have never seen the time zone tab other than grey however the timezone was automatically set according to selected location on the map.
    The timezone settings in Linux has no effect on the GUI. They are independent.

    #40765

    Ray
    Keymaster

    sakos is correct.

    To give you some more details: on OSPi, the firmware calls Linux’s time() function to obtain UTC time, and that’s offset by the time zone value stored in the settings to get your local time:
    https://github.com/OpenSprinkler/OpenSprinkler-Firmware/blob/master/OpenSprinkler.cpp#L299

    From jeeva’s screen shot, it looks like the location is still the factory default (Boston,MA), and so the time displayed on the screen shot is UTC-5:00 time. To change it, just go to Edit Options and change the location.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.

OpenSprinkler Forums OpenSprinkler Mobile and Web App Resets to default settings everytime I reboot and timezone