OpenSprinkler Forums Hardware Questions OpenSprinkler Pi (OSPi) Unable changing system time

  • This topic is empty.
Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #23166

    Austria
    Member

    Hi!

    I finished my irrigation system just 2 days ago. Everything works just fine.
    BUT – somehow I´m completely unable to change the system time to my local time.
    My timezone would be UTC+2, but it does´t change a thing to change the timezone to any other value.
    Systemtime remains unchanged.

    Could anybody help me?

    thanks,

    Guenther

    #28290

    Austria
    Member

    Problem solved.

    Only restarting the device changes the time setting……

    #28291

    Austria
    Member

    …sorry, problem just solved for a few seconds.
    Even after several reboots.
    Same situation.

    Device time cannot be changed.

    pls help……

    #28292

    Dan in CA
    Participant

    Are you using the raspi-config program on the Raspberry Pi to change the timezone? That is where the system time is set.

    sudo raspi-config
    4 Internationalisation Options
    I2 Change Timezone

    On thing that is not obvious is that you need to use the space bar on your keyboard to set/unset the timezone for your location.

    Dan

    #28293

    ashley2
    Member

    First, based on what you said, there is a timezone issue setting the rain delay. I’ll check it out (this is also causing TechFan to see the wrong day in preview page after a certain hour)……………….

    #28294

    Austria
    Member

    I´ve tried it on both GUI´s. Both with the same effect. It does´t change the time. Independent of the UTC+XX set.

    [/URL]

    [/URL]

    #28295

    Austria
    Member

    sorry, now bigger….

    #28296

    Samer
    Keymaster

    Based on your screenshots, it looks like you need to update your software.

    The version of OSPi you are running is rather old. If you can, please upgrade to the latest OSPi.

    I also believe you are using the PHP web app which is also quite dated. This is no longer developed and instead it’s recommended to use one of the available app store apps (mobile and desktop) or to directly access the controller (after updating your firmware).

    #28297

    Austria
    Member

    Thanks to “Dan in CA”, the problem is finally solved:
    ………………………………..
    Mac:
    Open Terminal
    Find open sprinkler IP adress
    ssh [email protected]
    (Next you’ll be prompted for the password for the pi login, by default on Raspbian the password is raspberry.)
    sudo raspi-config
    4 Internationalisation Options
    I2 Change Timezone

    -……………………………….–

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.

OpenSprinkler Forums Hardware Questions OpenSprinkler Pi (OSPi) Unable changing system time