• This topic has 2 replies, 2 voices, and was last updated 4 years ago by Ray.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #49492

    Anonymous
    Inactive

    Hi there… is there a good verified method to install an USB modem onto the OS Pi… so that it can be s=used to access the OS Pi from anywhere….through net?

    #49568

    Anonymous
    Inactive

    Hey Guys….

    After all trial and error and some little bit of learning from eLinux.org and other net surfing I have made the USB modem (Huawei e173 u1) work on my Raspberry Pi. (Though the Pi V2 B+ froze a couple of time in last week… which is another issues to be resolved!? Any Help is most welcome).

    Here are the Steps that I Followed to get the USB modem (Huawei E173 u1) going;

    0) After you have the Pi up and running with all normal updates… Upgrades… etc..etc.. as per the Standard http://www.raspberryPi.org
    1) Plugin the USB modem with an active SIM card in it.
    2) then ‘lsusb’
    3) check the Modem ID… which looks something similar like … ‘ID 12d1:1506’ followed by the Modem Brand name.
    4) this confirms your modem is in place and USB is detected.
    5) Now type ‘sudo apt-get install usb-modeswitch’
    6) once done reboot the Pi.
    7) Check for ‘slusb’ to confirm the USB modem is detected.
    8) if all is going well you will get something similar to ‘ID 12d1:1506 or ID 12d1:1510’ (note this ID for use in step 18 as USB_MODEM= “ID 12d1: nnnn”).
    9) now type ‘ sudo apt-get install ppp ‘
    10) then type into which ever folder you want to ‘ sudo wget “http://sourceforge.net/projects/vim-n4n0/files/sakis3g.tar.gz” ‘
    11) then ‘ sudo gunzip sakis3g.tar.gz ‘
    12) then ‘ sudo tar -xvf sakis3g.tar ‘
    13) then make the file executable with ‘ sudo chmod +x sakis3g ‘
    14) then ‘ sudo apt-get install libusb-dev ‘ this is have USB-lib
    15) then ‘ sudo ./sakis3g recompile ‘ Now cross your finger and have some thrill to expect the output… 🙂 this takes its time.
    16) Once this step is done after a few minutes…
    17) Edit the config file – type ‘ sudo nano /etc/sakis3g.conf ‘
    18) In the file have the below lines…

    OTHER=”USBMODEM”
    USBMODEM=”ID from step 8 ”
    USBINTERFACE=”0″
    APN=”APN of service provider/SIM”
    APN_USER=”user name from service provider/SIM”
    APN_PASS=”password from service provider/SIM”

    19) now from the folder in which the sakis3g is placed do ‘ sudo ./sakis3g connect ‘

    And bingo here we go with the connection and the light on modem should stay without a blink.
    (incase this does not work change the – USBINTERFACE=”1″ , then give it a try).

    Have fun. I found this working for me …. but I failed with wvdial. Any one has a better option do share.

    #50004

    Ray
    Keymaster

    Cool. Some other users also asked about USB modem options in the past. Will bookmark this.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.