OpenSprinkler Forums OpenSprinkler Unified Firmware Wrong time and date showing

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
  • #22404


    Hi Ray,
    I cant get my unit to show the correct date and time, I have reset several times and also powered off and on, its connected to the net and every thing else works fine.

    It is version 1.8.1 and shows device time of Mon, 03 Mar 2036 13:20:11 GMT +10 as Its in Australia.

    Is their a way to ask it to update the time?





    Actually found the problem, the ip of the router was wrong, it picked up the NAS media player address as the ip, not sure why.

    So I swapped the IP of the router and the Media player and after a reset it picked up the correct time.




    I’m having a similar problem.
    My version is 1.8.2 and the date shows 2036 for the year.
    The time has been working ok for the last 6-8 months and just recently stopped working.
    One factor is that I just installed NetTalk ( a VOIP telephone). I suppose this could have changed the setup.
    I don’t care about remote access for OpenSprinkler I just want to get the time running again.
    What are the steps to fixing this? I can’t find any Network features that let me manage IP addresses for OpenSprinkler.
    What am I missing?



    Re: managing OS IP address
    With DHCP on you can either take what your router gives you or have your router always provide the same address (via DHCP reservation in the router). If you want to give OS a static address, turn off DHCP (in options / advanced). You will then have the ability to add the IP and gateway address.



    Actually, firmware 1.8.2 did not support static IP assignment on the controller. First, can you update your controller to 1.8.3, which is the latest for OpenSprinkler 1.x? That did bring a few improvements with it although not quite sure all the changes.

    Otherwise, if you access the controller by IP in a web browser, you should be able to change the date and time manually.



    There are two possible reasons for the time drift: one is the RTC battery (the CR1220 battery). If you have a multimeter, check if the battery voltage is at least 2.7V. Otherwise you should replace the battery. Second, the DS1307 RTC chip might be defective. If so you can easily replace it. In either case, if the controller is set to perform NTP sync, it should obtain network time every 24 hours to stay in sync with the current time.



    I replaced the battery & now the date shows 0-0 and the time has started incrementing 0:1, 0:2 every minute so the RTC is functioning.
    When does the firmware try to sync to NTP after power up? I would have thought that it would try right away, but doesn’t look like it.

    Is there no way to set the date and time manually with hw 1.4u and firmware 1.8.2?
    If not, then why is there an option for NTP sync?
    That doesn’t make sense. If NTP is off how does one set the date and time?
    I don’t see any options for the date and time in the browser.

    Also 1.8.2 does support setting a static IP via the switches, but does not offer Options/Advanced via the browser.



    NTP sync is performed every time the controller reboots — unless if you had set NTP sync option to Off. Another reason it can’t perform NTP sync would be if your router cannot access Internet, or if you’d set static IP but didn’t set the correct gateway (i.e. router IP), such that the controller will send NTP request but cannot receive the response.

    Firmware 1.8.2 is a while back, so I can’t quite remember how to set a date/time manually — I believe it allows you to do so through the web interface.



    I don’t want internet access to my sprinkler network, so it looks like the controller is useless if it can’t access NTP.

    Please don’t suggest that I manually set the date and time. IT CAN’T BE DONE WITH MY HW & SW configuration.
    The switches don’t offer it and the Web server does not offer an ‘Advanced’ selection on my Options page as some have suggested.
    I could upgrade to 1.8.3 but in looking at the release notes, there are no changes that would add functionality for setting the date and time.

    And with my hw version, I think that 1.8.3 is the latest compatible sw version.

    Early adopters always pay the price. I’m dead in the water now.



    Can you host an NTP server locally on your network? If so, you could change the NTP address to match.

    I understand your frustration but also understand your configuration is over two years old and support can only go so far without sacrificing forward momentum with newer software/features. Unfortunately, hardware version one was quite limited and doesn’t have the resources to run our newer firmware.

    Thank you for your understanding.



    I would think 1.8.3 leaves an option for you to manually set time. I will check. Perhaps a work-around is to first flash the firmware to an earlier version (like 1.8.0 or something), which gives you the ability to manually change time. Once the time is set, it’s remembered in the RTC, and they you can flash to a more recent firmware.



    OK, so I just found that firmware 1.7 allows you to set time manually. To do so, first flash your controller with firmware 1.7. Then open a browser and type in the IP address (you can’t use app because the app doesn’t support firmware 1.7 which is a very old version). Go to Options, and check the ‘Change time?’ checkbox. Underneath that type in your current time, then password (opendoor), and click on Submit.

    Once this is done, the RTC should remember the time, so when you upgrade to firmware 1.8.3 the time should be preserved.

    If you can’t find the firmware 1.7, it’s in folder ‘osFirmwareUpdater/Firmware/OpenSprinkler_v1.4’.

    Ideally you should have OpenSprinkler installed on a network with Internet access so it can perform NTP sync. Without NTP sync, the time will start to drift.



    Thanks Ray for looking this up for me. I know how painful it can be to check through old versions looking for a feature.
    Before I try downgrading the firmware, I thought I might try to connect to NTP one more time to try and get the time set.

    So I re-booted the OpenSprinkler and then looked at the event log of the router (Netgear C6300). This is the event I see:

    Jun 29 09:24:29 2015 Error (4) DHCP RENEW WARNING – Field invalid in response v4 option
    Jun 29 09:24:29 2015 Notice (6) DHCP Renew – lease parameters time server-

    I am able to connect to OpenSprinkler with my browser & can make changes and manually control the sprinklers.

    Switch Settings:
    NTP Yes
    DHCP No
    Gateway (My router)
    Auto Reconnect Yes

    Does this provide any clue as to what might be happening?

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.

OpenSprinkler Forums OpenSprinkler Unified Firmware Wrong time and date showing