OpenSprinkler Forums OpenSprinkler Unified Firmware Announcing OpenSprinkler Unified Firmware 2.1.9

Viewing 12 posts - 51 through 62 (of 62 total)
  • Author
    Posts
  • #64826

    ferenc.nemeth
    Participant

    hi

    problem solved !

    the card was bad. Yesterday I have formated the original card and it looks good in laptop.
    I have no other card at home, but this time I have an idea that I have an other device at home.
    It has some other plroblems, and there is an a card in it. So I changed the cards, and it works!!

    Thank you very much for your help and your time.

    Last question. Can I sand you back the other device? Last year we had some letter cahnging about it.
    When that device went wrong I bought an other one because it was summer, I have to use that.

    First time that device does not handle the extender board.
    This time I cannot switch it on.

    best regards feri

    #64833

    Ray
    Keymaster

    Sure, please reply to whichever last email you are referring to so that we can continue from there and arrange for a support request.

    #64859

    vpl
    Participant

    I had this same problem. Turning on debug gave a lot of errors along the build process. My installation is several years old, so I decided to swap in a new sdcard with the latest raspbian image and everything worked fine after that.

    tl;dr Try upgrading raspbian.

    #65102

    Zsolteeca
    Participant

    I would like to upgrade my device to the new firmware with GUI based updater but it stuck on the downloading firmware option..
    In the begin I can’t see version numbers it will be seen on the picture I have taken..
    gui error

    I would like to use this updater because it is simple and I like it….
    I used the run as admin mode tried the compatibility mode but these were unsuccessful things..

    Thanks for help!

    #65113

    Ray
    Keymaster

    If you want to use the GUI based updater, do NOT click on Download Firmware — the updater program hasn’t been changed for a long time and the original download link is no longer available. Instead, the firmware files are together with the GUI program. So all you need to do is to Upload. Again, do NOT click ‘Download Firmware’.

    Please also note that the GUI program only has firmware up to 2.1.7. If you want to update to 2.1.9 you should follow the instructions and use the avrdude program to update.
    https://openthings.freshdesk.com/support/solutions/articles/5000832311-opensprinkler-2-x-firmware-update-guide

    The GUI program is just a wrapper for the avrdude command. But as operating system updates often render previously compiled programs obsolete, we don’t have enough resources to keep updating the GUI program and make sure it works with the current operating systems. So we stopped maintaining the GUI and instead recommend you to use avrdude, which does not have operating system compatibility issues.

    #65176

    smhaller
    Participant

    Dear all

    Recently I’ve got my OS active which is really a good thing. But one open point is the soil moisture metering. Already before reading here I found the description refered to in .
    Which is from my point of view not a bad one. Also vegetronix sounds reasonable.

    With the first option I would miss the possibility of data logging. I mean it would be interesting to have a chart with the reported values.
    With vegetronics I’m not sure if the sensor is made ready for permanant use (keep in the ground) and I still don’t have a data logger.

    Another option would be to combine it with https://sensebox.kaufen/product/sensebox-mini
    But this board is a bit an overload to just have the data of the soil sensor.

    BTW: the logged values would be transmitted to openHAB

    So I struggle a bit to decide what project to focus on. What would you guys suggest?

    Kind regards
    Stefan

    #65179

    Ray
    Keymaster

    Some of the design challenges of a soil sensor include how to power it over long time, and how to transmit the data out. For good and reliable sensing, it’s often necessary to bury the sensor underground, but that makes it harder to power over a long time and have a reliable wireless transmission method. Many years ago I took a look at some of the available options:

    Reverse Engineer a Cheap Wireless Soil Moisture Sensor


    but none of them seems a great option. I am not sure what’s the state of the art. I see Vegetronix mentioned quite often — the VH400 sensor is a wired sensor, to go wireless you need a WiFi hub, powered by 9V battery. I don’t know if this is a long-term solution or not — it seems cumbersome to have to replace the battery once every few months. So honestly I don’t know which way to proceed.

    #65645

    NOV6
    Participant

    I have tried to install Firmware 2.1.9 on my Open Sprinkler 2.3 DC hardware but it is not successful.

    The installation procedure seems to work without any errors but no firmwware change occurs. I am not sure what the problem is.

    Here is a screenshot of the procedure in terminal.

    And also, a screenshot of my

    #65666

    Ray
    Keymaster

    Please note that in the command you ran, ‘_U’ is a typo, it should be ‘-U’ — i.e. a dash, not a underline.

    Also, what follows that is NOT ‘flash:wos_219.hex’, it should be ‘flash:w:os_219.hex’. It’s better that you copy-paste the command from the instructions:
    https://openthings.freshdesk.com/support/solutions/articles/5000832311-opensprinkler-2-x-firmware-update-guide
    which will reduce the chance of error in typing the command.

    • This reply was modified 3 months ago by Ray.
    #65731

    NOV6
    Participant

    Thanks, successfully installed!

    #65941

    Nicola
    Participant

    I saw in the donwload section what looks like a firmware 2.1.9 v3:

    os_219_3.hex 2020-04-06 00:00 218K

    Is that it? what are the difference with v2/v1 ?

    #65972

    Ray
    Keymaster

    Minor revisions (like 2.1.9 (0) or (1) or (2) or (3)) are usually bug fixes. Details can be found at github commit history:
    https://github.com/OpenSprinkler/OpenSprinkler-Firmware/commits/master
    For example, minor revision (3) has the following changes: fix bug with program moveup api; increased ether buffer size for OS 2.3 and 3.0; improve NTP; fix bug in server_change_station that causes buffer overflow when there are a large number of zones.

    The latest firmware is the default firmware file you see at the download folder. Previous firmwares are in the archived subfolder.

Viewing 12 posts - 51 through 62 (of 62 total)
  • You must be logged in to reply to this topic.

OpenSprinkler Forums OpenSprinkler Unified Firmware Announcing OpenSprinkler Unified Firmware 2.1.9